장바구니

등록된 상품이 없습니다
합계: 0

최근 본 상품

등록된 상품이 없습니다
워드프레스 전문가들이 선택한 필수 플러그인
    상품 Q&A
    Home / 상품 Q&A
    글보기
    구글 소셜 로그인 문제
       
    2024-06-27 13:49:28

    질문을 하시기 전 "망보드 유용한팁" 게시판과 "망보드 강의" 게시판 검색을 통해 해결하지 못한 내용만 

    아래의 양식을 참고하셔서 답변자가 이해할 수 있도록 최대한 자세히 작성해 주시기 바랍니다.


     

    [질문 양식]

     

    1. 질문 검색 키워드 : 

      

    2. 질문 내용 : 

    홈토리님 답변을 보고, 프로젝트 삭제 후   재생성하고 그대로 다시 해봤습니다. 

    근데 계속 같은 문제가 발생하였습니다.
    현재 제 환경은 PHP8.2-FPM 입니다.
    PHP7.4-FPM으로 다운그레이드도 해봤습니다만 여전합니다.
    카카오소셜은 잘되는데...구글만 속을 썩여서 일단 구글소셜은 포기하려 합니다. ㅠㅠ

    마지막으로 구글로그인시 서버에서 발생하는 nginx에러로그를 남기겠습니다.

    2024/06/27 13:42:09 [error] 3549173#3549173: *585341 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Class "GuzzleHttp\Message\AbstractMessage" not found in /home/proxmox/web/proxmox.co.kr/public_html/wp-content/plugins/mangboard/plugins/sociallogin/sdk/google/vendor/guzzlehttp/guzzle/src/Message/Request.php:12

    Stack trace:

    #0 /home/proxmox/web/proxmox.co.kr/public_html/wp-content/plugins/mangboard/plugins/sociallogin/sdk/google/vendor/composer/ClassLoader.php(444): include()

    #1 /home/proxmox/web/proxmox.co.kr/public_html/wp-content/plugins/mangboard/plugins/sociallogin/sdk/google/vendor/composer/ClassLoader.php(322): Composer\Autoload\includeFile()

    #2 /home/proxmox/web/proxmox.co.kr/public_html/wp-content/plugins/mangboard/plugins/sociallogin/sdk/google/vendor/guzzlehttp/guzzle/src/Message/MessageFactory.php(84): Composer\Autoload\ClassLoader->loadClass()

    #3 /home/proxmox/web/proxmox.co.kr/public_html/wp-content/plugins/mangboard/plugins/sociallogin/sdk/google/vendor/guzzlehttp/guzzle/src/Client.php(120): GuzzleHttp\Message\MessageFactory->createRequest()

    #" while reading response header from upstream, client: 115.21.95.10, server: proxmox.co.kr, request: "GET /?mb_social=login&auth=google&code=4%2F0ATx3LY7cBJJlJfn1d2452bRvVBfo4gTi65UINKuFcF0hcNBVSK6cWcj11Y2Zd4nEO3oERA&scope=email+profile+openid+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.profile+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email&authuser=1&prompt=consent HTTP/2.0", upstream: "fastcgi://unix:/run/php/php8.2-fpm-proxmox.co.kr.sock:", host: "proxmox.co.kr", referrer: "https://accounts.google.com/"

    ^C

     

       - 

        


    댓글 0|  조회수 17
    답 변
    글보기
    user icon    
    2024-06-27 16:28:02

    안녕하세요! 망보드 고객지원팀입니다. 

    저희가 확인해 보니 PHP 8.2 버전에서는 구글 SDK가 업데이트 되어 오류가 발생할 수 있는 것으로 확인이 됩니다.

    저희가 첨부해드린 구글 SDK 파일을 /wp-content/plugins/mangboard/plugins/sociallogin/sdk/google 경로에 덮어쓰기로 업로드 하신 후 확인해 보시기 바랍니다.

    감사합니다.



    첨부파일google-sdk-php8.2.zip (1.23MB)
    댓글 0